
 

MegaStat Frequently Asked Questions 

 

1. Will MegaStat run on an Apple Mac computer? 

MegaStat is available for Mac Excel 2011.  It has most of the features and works the same way as 
the Windows version although the appearance and some of the dialog boxes are slightly 
different.  The file format is the same as the Windows version. 

It will not work with Mac Excel 2008 since that version did not support add-ins.  MegaStat for the 
Mac appears to work with Mac Excel 2004 although not all options have been tested.    See FAQ 
item 22 below for details if you have Mac Excel 2004. 

Another possibility is to use Boot Camp to run Windows 7 and the Windows version of Excel or 
use emulation software such as Parallels, VMware Fusion, or VirtualBox. We have used the 
BootCamp approach and it works fine.  We have not tried the emulation approach, but some 
users have reported that it works. 

2. Will MegaStat run on all versions of Excel and Windows? 
 
MegaStat 10.3 has been tested on 32 bit versions of Excel 2007, 2010, and 2013.  As of May 1, 
2013 MegaStat is no longer supported on Excel 2003 or earlier. 
 
MegaStat 10.2 has been tested with 32 bit versions of Microsoft Excel 2007, Excel 2010 and Excel 
2013.  The MegaStat menus, Help, and documentation have been updated to focus on Excel 
2007/2010/2013.  See FAQ item 23 for instructions on how to use MegaStat 10.2 (and earlier) 
with Excel 2013.  MegaStat 10.2 and earlier may run on Excel 2003, but it has not been recently 
tested and as of May 1, 2013 it is no longer supported on Excel 2003 or earlier. 

MegaStat will work with 32 and 64 bit versions of Windows XP, Windows Vista, Windows 7, and 
Windows 8, but it will not work 64 bit Excel.  The standard Excel implementation is 32 bit and 
there is no advantage in using 64 bit Excel except that it can handle larger data sets with several 
million values; however, if you have that much data, Excel would probably be too slow to be 
useful. You will probably get a Compile Error if you try using MegaStat with 64 bit Excel. 
 
We have not tried all combinations of Windows and Excel versions.  It is best to have the Excel 
version more or less consistent with the Windows versions.  For example, running Excel 2013 on 
Windows XP might be a problem.  The latest updates of Excel and Windows are recommended. 
 
 

3. How large is MegaStat? 

The MegaStat 10.3 download file is approximately 2MB.   

MegaStat does not require a large amount of memory.  If you can run Excel, you can probably run 
MegaStat. 

 



4. What are the differences between MegaStat 10.2, and 10.3? 

MegaStat 10.3 is mostly the same as earlier versions with a few (mostly internal) 
improvements. The main difference with MegaStat 10.3 was a change in the installation 
procedure to make it compatible with Excel 2013 and the installation no longer installs the 
User’s Guide on the Start menu since Windows 8 eliminated the traditional Start menu.  
There were a few very minor formatting changes, but version 10.3 is essentially identical to 
version 10.2 and earlier. 

Technical note:  With version 10.3 the add-in file is now megastat.xlam; previous versions 
were megastat.xla. 

 Changes with version 10.2 were: 

1. There was a new installation program. Our previous installer was no longer being supported 
so we had to change. 

2. The help system was converted from WinHelp to HTML help. 

3. The MegaStat User’s Guide (previous known as Getting Started with MegaStat) was expanded 
and updated and uses Excel 2010 screenshots.  
 

5. Why was the help system changed on version 10.2? 

The WinHelp system used by version 10.1 and earlier of MegaStat was no longer being directly 
supported by Microsoft and Vista later versions required a download for help to function and 
even then the message box Help buttons did not function.   
 

6. Why is it important to uninstall earlier versions before installing version 10.2 or 10.3? 

Since versions 10.2 and later changed to a different installer program, they cannot automatically 
uninstall version 10.1 or earlier and you could end up with two MegaStats on the Add-Ins ribbon. 
If you are updating version 10.2 or later, they will automatically uninstall (See also FAQ #10).  Use 
Control Panel -> Programs to uninstall if necessary. 
 

7. Will MegaStat run on a network? 

MegaStat was not developed specifically for network use and is not supported for network use; 
however, some users have reported successful network usage.  FAQ #16 might be useful for 
network installations. 

 Check with McGraw-Hill regarding network licensing before attempting a network installation. 

The switch to HTML help with MegaStat 10.2 may be a problem with networks because of 
Microsoft security regarding .chm files.  Some work-arounds might be found on the Internet. 
 
 



8. Where are the MegaStat files stored? 

With MegaStat 10.2 & 10.3 the files are stored as follows:  
 
The MegaStat.xla (or.xlam) add-in file and the MegaStat.chm help file are stored using the 
installer program’s <AppData> variable.  On Windows 7 and Vista this location  is: 
C:\Users\{yourusername}\AppData\Roaming\Microsoft\AddIns. On Windows XP this location is: 
C:\Documents and Settings\Administrator\Application Data\Microsoft\AddIns 
 
Other support files and the Megastat_Users_Guide.pdf are stored using the installer program’s 
<CommonAppData> variable.  On Windows 7 & 8 and Vista this location is  
C:\ProgramData\MegaStat (Note this is ProgramData, not Program Files.)  On Windows XP this 
location is:  C:\Documents and Settings\All Users\Application Data\MegaStat 
 
C:\ProgramData is a hidden system folder so you may need to use Windows Explorer -> Tools -> 
Folder Options -> and click ‘Show hidden Files, folders and drives’. 
 

9. The column widths don’t look correct on my MegaStat output.  What happened? 

When MegaStat appends new output at the bottom of an existing output sheet, it adjusts the 
column widths for the most recent output and that may not look correct for the output above.  
You can usually adjust the columns to make it look OK.  If having proper column widths is 
important for all output, start a new Output sheet before each output. 

10. Why do I have two MegaStat items on my Add-ins ribbon? And what do I do about it? 

This is probably because you did not uninstall a prior version before installing version 10.2 or 
later. (see FAQ #6).  The best thing would be to see if both of the MegaStats work, and, if so, go 
to the Utilities menu and click Remove or Deactivate (these both do the same thing).  Then go to 
Control Panel and uninstall any MegaStats you find there.  Finally, re-install the latest version of 
MegaStat. 

You may also right-click one of the MegaStat items and select ’Remove Custom Command’. 
 

11. Why doesn’t the Output sheet have gridlines? 

We feel the output looks cleaner without the Excel gridlines; however, you can turn them back on 
with View → check gridlines. 

12. MegaStat is installed, but it has disappeared from the Add-Ins ribbon.  What happened? 

This may happen occasionally; however, it happens so rarely that we have never been able to 
determine what (if anything) causes it and if anything can be done about it, but there is an easy 
fix.  Use Excel Options → Add-Ins → Go to get to the Add-ins list.  Uncheck MegaStat and click OK.  
Then get back to the Add-Ins list and check MegaStat again and click OK.  That usually works.   If 
not, try exiting Excel and restarting. 
 



13. I get errors when I enter decimal values, what is the problem? 

This is probably caused by changing the decimal separator from a period to a comma.  MegaStat 
requires that the decimal separator be a period. 

 

14. I’m getting a  ‘Subscript out of range.’ Message.  What is the problem? 

This is usually caused by trying to run MegaStat by double-clicking the MegaStat.xla file.  This 
might work with Excel 2003 and earlier, but since Excel 2007, MegaStat has to be run by being 
setup as an add-in via Excel Options.  See the MegaStat Installation instructions for details. 

15. MegaStat doesn’t load or asks for a MegaStat password.  What causes this and what can I do? 

This happens rarely and we have not been able to replicate it; however, this issue appears to be 
related to the Visual Basic for Applications program within Office, and some updates that may not 
have been performed in the background on a user's particular machine.  Search for files with the 
extension of .exd on your hard drive.  For Windows Vista and Windows 7 users these will usually 
be found in the \users folder area.  It would be best to do a search across the entire hard drive, 
and not just on the \users folder.  Once you find the files you should delete them.  The files will 
be re-created by Windows on an as-needed basis. 

Also, MegaStat requires that you enable macros on the security options. 

16. Can MegaStat be used without running the installer program? 

It is generally preferable to set up MegaStat via the installer program since this will put the files in 
the default locations and will allow uninstallation via the Control Panel.  However, you can copy 
MegaStat.xlam (or MegaStat.xla) and MegaStat.chm to any folder and then Browse to that folder 
from the Add-Ins list. 

17. I cannot get Help to work with MegaStat.  What can I do? 

This probably means you are using MegaStat 10.1 or earlier with Windows Vista or later.  The 
best solution would be to upgrade to MegaStat 10.2 (see FAQ #4 and #5).  If you need to continue 
with the earlier version of MegaStat, you can go to the Microsoft website and search for the 
WinHelp32 download patch. 

If you install MegaStat manually, make sure MegaStat.chm is in the same folder as 
MegaStat.xla[m]. 

18. Can I view and print the MegaStat help file. 

You may double-click the MegaStat.chm file to open it and there is an option for printing.  (See 
FAQ #8 for the file location.) Help files are viewed with the Windows help viewer program, not 
MegaStat. 
 
 



19. Is MegaStat output ‘live’?   I.e., will the output automatically update if I change my input data? 

MegaStat Output sheets consist of numbers and text, but not formulas and thus they do not 
automatically update if you change your data.  While live output seems like a good thing, most 
MegaStat options involve calculations and operations beyond simple formulas.  Also, live 
formulas can cause problems if output is pasted into other applications because the links can be 
broken or the data inadvertently changed.  It is very easy to re-run MegaStat options after 
changing the data and that has the advantage of having the previous output for comparison. 

One exception is the Generate Random Numbers option that can display live formulas. 

However, all MegaStat charts are ‘live’ and they are linked to values on the Output sheet or on a 
ChartDataSheet (see the MegaStat User’s Guide).  Scatterplots are linked to your input data.   

The reason charts are live is so you can click on them and see what values are being used.  
However, you need to be careful when you paste a chart into another Excel file or another 
application, such as Word.  See FAQ #20 for details. 

20. I copy/pasted a MegaStat chart into another application, it does not display properly.  What 
can I do? 

If you paste a MegaStat chart into another application, the default paste operation usually 
maintains links to the original data. That will probably work OK; however, it may be possible for 
the links to the original file to be broken if the original file is deleted, moved, or changed. 
 
It is probably safest to do the chart creation and editing in Excel and then use Paste Special to 
paste a fixed image of the chart into the other file.  This link discusses the guidelines for the 
various picture formats:  http://support.microsoft.com/kb/320314. I usually use the Enhanced 
Metafile or .jpg option.   
 

21. Does MegaStat use the Windows registry? 

MegaStat does not directly use the Windows registry; however, the installer program will create 
some registry entries and Excel uses a couple entries related to add-ins. When an add-in is 
activated by being checked in the add-ins list, Excel creates a registry key like this:  
HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Excel\Options. Note: the ’15.0’ in the 
registry key refers to Excel 2013.  The value for Excel 2010 is 14.0, Excel 2007 is 12, and Excel 
2003 is 11.0. 

There will be several values listed for this key, but the ones of interest for add-ins are OPEN, 
OPEN1, OPEN2… depending on how many previous add-ins have been activated. Each entry 
stores the name of an active add-in file (and its location if it is not in the add-ins folder).  When 
the add-in is unchecked, the registry entry is removed the next time Excel is exited. Excel uses this 
key to know which add-ins to show as checked in the add-in list. 

If you use Browse to find an add-in, Excel creates another registry key with the add-in name and 
location: HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Excel\Add-in Manager.  Excel 
does not automatically clear this entry if the add-in is removed. 

http://support.microsoft.com/kb/320314


22. How do I install MegaStat for Mac Excel 2004? 

MegaStat has not been tested with Mac Excel 2004 and is not supported; however, some 
preliminary testing indicated that it might work, at least partially. 

The Mac MegaStat installer will create a folder called: 

 Applications : Microsoft Office 2011 : Office: Add-ins 

From that folder use Finder to copy MegaStat.xla and the MegaStat Help folder to: 

Applications : Microsoft Office 2004 : Office: Add-ins 

that should have been created when you installed Excel 2004.  You then will see MegaStat in the  
add-in list when you do Tools  -> Add-Ins in Excel. 

After copy the files to the 2004 directory, you my delete the 2011 directory if you do not have 
Excel 2011 on your system. 

Another possibility would be to use the Select button on the Excel -> Tools -> Add-Ins dialog box 
to point to the  Applications : Microsoft Office 2011 : Office: Add-ins folder. 

23. How can I use MegaStat 10.2 and earlier versions with Excel 2013? 

Version 10.3 changed the installation procedure so that MegaStat automatically works with Excel 
2013.  The main issue was that Excel 2013 expects .xlam add-in files rather than .xla in order for 
the add-in to automatically appear on the ribbon.  However, the steps below will allow you to 
install the version 10.2 (and earlier) of MegaStat with Excel 2013. 
 
1. Run the MegaStat installation program if you haven't already done so. 
 
2. Open Excel and click: File > Options > Add-Ins 
You should see MegaStat in the Inactive Application Add-ins list.  Make note of the location of 
MegaStat.  You may need to resize the window to see the entire address.  You will need enter this 
address in step 4 and you will need to get it just right.  It might be a good idea to write it down.  
Note the “:” and the backslashes “\”, not “/”.  The MegaStat.xla at the end is not part of the 
location address. 
 
3. Click OK to close the window. 
 
4. In Excel click File > Open > Computer > Browse 
 
The AppData folder is a hidden folder so you will not see it in the folders list.  You will need to 
type the location address in the address box at the top of the screen.  Just click in the box and 
start typing the address you noted in step 2; do not type MegaStat.xla at the end.  When you are 
done typing press the Enter key and MegaStat.xla should be listed in the window. 
 



Double-click MegaStat.xla or single-click it and click the Open button. MegaStat will now be on 
the Add-Ins ribbon. 
 
MegaStat will be on the Add-Ins ribbon for any subsequently opened Excel files during the 
session, but it will go away when you exit Excel. 
 
5. If you want MegaStat to be on the Add-Ins ribbon every time you open Excel, click: 
            File > Options > Add-Ins > Go.  Click the checkbox next to MegaStat in the Add-Ins 
            list and OK to exit.    
If you don't do this step you will need to do step 4 each time you want to use MegaStat; however, 
the procedure will be easier because when you click File > Open, MegaStat.xla will now be on the 
Recent Workbooks list.  In fact, you can click the icon to the right of the file name to 'Pin this 
item to the list' and then it will always be at the top. 


